Jump to content
Gee_suss

Copy of website to test server not displaying correctly!

Recommended Posts

I need to put a link in the footer and create a new privacy page for this website (www.mala.co.uk). The footer is in php and is pasted into the code of each page. What I have done is created a test server and I have copied all of the files via ftp to this new location so I can make the changes.

What I have found is that the website does not display correctly and none of the CSS or PHP is showing. Even though all I have done is copy all the files from one place to another.

I did not create the website and I am wondering if the previous developer has done something to stop it being amended or copied. I am somewhat a novice but though I would be able to make the simple changes.

PLEASE HELP! Kind Regards...

mala1.jpeg

mala2.jpeg

Share this post


Link to post
Share on other sites

Most likely because of absolute paths to the stylesheets etc. Open chromes developer tools and check for missing resources under the network tab.

Share this post


Link to post
Share on other sites

Um, I don't think the test server is running php? Went to the demo and in the source code of http://malatest.gavinrain.co.uk/ has <?php include("header.php"); ?> which means it didn't include http://malatest.gavinrain.co.uk/header.php which is where all the styles are.

Forgot to say if php is running, then I can only assume you're trying to include a file with php in a .html page which won't work, the page including must be a .php page. 

Edited by BrowserBugs
Forgot summit

Share this post


Link to post
Share on other sites
23 minutes ago, fisicx said:

Agree with @BrowserBugs. There are also a number of other issues with the site that could be addressed while you are doing the updates.

Oh yes this is a site that could be massively improved!. Please tell me what you have seen?

Share this post


Link to post
Share on other sites
2 hours ago, BrowserBugs said:

Um, I don't think the test server is running php? Went to the demo and in the source code of http://malatest.gavinrain.co.uk/ has <?php include("header.php"); ?> which means it didn't include http://malatest.gavinrain.co.uk/header.php which is where all the styles are.

Forgot to say if php is running, then I can only assume you're trying to include a file with php in a .html page which won't work, the page including must be a .php page. 

Hello. I just checked with the domain provider to check if PHP is running on my account, they said it is so PHP must not be the issue. The previous developer has used a PHP header and footer to what I assume is to make those elements consistent across all pages like a template. What I want to do is just add a small link named 'Privacy' to the footer and then have that linked to a page with the privacy terms and conditions on it.

But I am having problems just getting it to look right. In my experience I have only ever used HTML and CSS so I am really confused. It is only a simple change I have to make but I am lost to where to start!.

Share this post


Link to post
Share on other sites
4 hours ago, Nillervision said:

Most likely because of absolute paths to the stylesheets etc. Open chromes developer tools and check for missing resources under the network tab.

Hello. Do I have to change the paths in the actual pages or in the CSS style sheets? I will take a look in chrome for sure.

Share this post


Link to post
Share on other sites
8 minutes ago, Gee_suss said:

Oh yes this is a site that could be massively improved!. Please tell me what you have seen?

I'm a bit busy right now but the obvious thing missing from every page are your contact details. They should be in the footer along with links to your privacy policy.

The site isn't working because it may have been saved locally as an HTML file not PHP. Check the filenames and make sure they are index.php not index.html.

If you want help send me a PM. It's probably a 5 minute fix so I can do this for free.

Share this post


Link to post
Share on other sites
35 minutes ago, fisicx said:

I'm a bit busy right now but the obvious thing missing from every page are your contact details. They should be in the footer along with links to your privacy policy.

The site isn't working because it may have been saved locally as an HTML file not PHP. Check the filenames and make sure they are index.php not index.html.

If you want help send me a PM. It's probably a 5 minute fix so I can do this for free.

Hey fisicx, I hope all is well and you are having a splendid day. Many thanks for your reply. Yes I totally agree the website can be massively improved for sure. I hope hope that this change would be simple and I could create a test server and copy it across and then work on it myself. I am having the problem getting it to display properly.

The pages are html with the header and footer pasted in as PHP. This is a new technique for me but I suppose the last developer did it in his own way.

All I have done is a direct copy from one place to another. What I don't understand is how I can do this and it does not display properly. It shows correctly on its original server.

Share this post


Link to post
Share on other sites

It is a very simple thing to do. What is the file name of your homepage?

Is it index.html? If so rename it to index.php

Share this post


Link to post
Share on other sites
24 minutes ago, fisicx said:

It is a very simple thing to do. What is the file name of your homepage?

Is it index.html? If so rename it to index.php

Hi fisicx. It worked! the index page is now displaying correctly, many many thanks, it is much appreciated. But the problem is also when I click the link 'HOME' even though I have changed the page from html to php it is not working correctly.

Is there a quick answer why it is html on the original server and displaying correctly? I will have to do this for all of the pages now?

Would you recommend PHP for developing webpages?

I now have to create a new privacy page and add a small link in the footer.

Edited by Gee_suss
Addition after testing the site

Share this post


Link to post
Share on other sites

It's probably HTML on the server because they did some sort of URL rewrite (because they don't understand 301 redirects).

You will need to save every page as .php

Or better still move the whole site to a CMS and discover a whole new world. You will realise what you have been missing for so long.

Share this post


Link to post
Share on other sites
14 hours ago, fisicx said:

It's probably HTML on the server because they did some sort of URL rewrite (because they don't understand 301 redirects).

You will need to save every page as .php

Or better still move the whole site to a CMS and discover a whole new world. You will realise what you have been missing for so long.

A content management system? implemented through wordpress perhaps?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Gee_suss
      Hello. I have a curious case of a missing footer. I needed to add a lot of text to a page so the page is very long. When I first started to develop the text the footer was still there but as more text was added the footer suddenly disappeared. I find this very strange and I would like the footer to come back.
      Here is the link. www.mala.co.uk/privacy
      If you have a look at the other pages you will see the footer I mention above. Any ideas?
      Many thanks in advance.


    • By milanrehor
      Hello, I should have a question. We develop our e-shop and try to link the instagram feeds with our site (create a gallery of images on a certain hashtag). Despite the instafeedjs (it's jS, but maybe another alternative will be needed - PHP, for example), it worked good just for a specific ID. The problem is that I need photos from the entire instagram, which are filtered to a certain hastag eg #KFC. Does anyone have experience with it? Does anyone know how to do it? Or does anyone have a link where the information needed to look for it?
      We do not use any CMS due to bad experience, not only in our group, but in general. We write everything from base (HTML, CSS, JS, etc.)
      Thank you very much in advance, any answer would help me.
      PS: Sry for my bad English :p :D
    • By Roberto182
      I am looking to create a new website and was hoping someone could recommend a reasonably priced designer/company who I could work with? 
    • By Roberto182
      Just a quick question. If I have a good idea for a new website and I am hiring someone to do it for me, do I need some sort of patence in place to stop someone else stealing my idea? 
  • Recently Browsing

    No registered users viewing this page.

  • Member Statistics

    • Total Members
      58,259
    • Most Online
      4,970

    Newest Member
    BarbaraBlanc
    Joined
  • Forum Statistics

    • Total Topics
      65,768
    • Total Posts
      453,362
×